0 Members and 1 Guest are viewing this topic.

AuthorTopic: Enable WMI (Windows Management Instrumentation)  (Read 2270 times)

Offline aegkaluk

  • Administrator
  • Hero Member
  • *****
  • Posts: 1098
  • Total Like : 0
    • Email
« on: 11, 03, 2013, 12:42:39 »
1. Enable remote WMI requests

This setting is usually all that needs to be changed to get WMI working. (Steps 2 and 3 are typically not needed, but they might be in some circumstances)

1. On the target server, go to Administrative Tools -> Computer Management.
2. Expand 'Services and Applications'
3. Right click for Properties on 'WMI Control'.


4. Select the Security tab
5. Press the Security button


6. Add the monitoring user (if needed), and then be sure to check Remote Enable for the user/group that will be requesting WMI data.


At this point go back and see if this fixes the problem. It might take a couple of minutes for the reports to re-generate.

2. Allow WMI through Windows firewall

All users (including non-administrators) are able to query/read WMI data on the local computer.

For reading WMI data on a remote server, a connection needs to be made from your management computer (where our monitoring software is installed) to the server that you're monitoring (the target server). If the target server is running Windows Firewall (aka Internet Connection Firewall) like what is shipped with Windows XP and Windows 2003, then you need to tell it to let remote WMI requests through2. This can only be done at the command prompt. Run the following on the target computer if it is running a Windows firewall:

   
Code: [Select]
  netsh firewall set service RemoteAdmin enable
Ref : http://www.poweradmin.com/help/enableWMI.aspx